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VISION & MISSION 
 

 

INSTITUTE VISION & MISSION 
 

 

VISION 

 To create knowledge based society with scientific temper, team spirit and dignity of 

labor to face the global competitive challenges 

 
MISSION 

 

 To evolve and develop skill based systems for effective delivery of knowledge so as 

to equip young professionals with dedication & commitment to excellence in all 

spheres of life 

 

 
DEPARTMENT VISION & MISSION 

 

 

 

 

VISION 
 

 To be recognized for quality education in the field of Mechanical Engineering and 

identified for its innovation & excellence 

 
MISSION 

 

 
 To provide education that transforms students through rigorous teaching and thought 

process to fulfill the needs of the society and industry 

 To collaborate with leading industry partners and other academic & research 

institutes around the world to strengthen the education and research ecosystem. 

 To prepare students with life-long learning for their career by fostering in them the 

ethical & technical capabilities pertinent to mechanical & allied engineering. 
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RTU SYLLABUS AND MARKING SCHEME 
 

 
 

 

7ME4-21: FEA LAB 

Credit: NA Max. Marks: 100 (IA:60, ETE:40) 

0L+0T+2P End Term Exam: 3 Hours 

 

S. No. 
NAME OF EXPERIMENT 

 

1. Introduction to ANSYS Workbench 

 

2. Structural analysis of a cantilever beam 

 
3. Steady state thermal analysis of “car brake disc” 

 

4. Modal Analysis of Cantilever beam 

 

5. Comparison of Stress Concentrated Loads 

 

6. Analysis of Axis-Symmetric Solids 

 

7. Analysis Stepped Shaft in Axial Tension 

 

8. Introduction to MATLAB 

 
9. Modal Analysis of Cantilever beam by MATLAB 
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EVALUATION SCHEME 
 
 

I+II Mid Term 

Examination 

Attendance and 

performance 

End Term 

Examination 

 

Total 

Marks 
Experiment Viva Total Attendance Performance Total Experiment Viva Total 

22 08 30 08 22 30 22 08 30 75 

 
 

DISTRIBUTION OF MARKS FOR EACH EXPERIMENT 

 

Attendance Record Performance Total 

2 3 5 10 
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LAB OUTCOME AND ITS MAPPING WITH PO & PSO 
 

 

LAB OUTCOMES 

After completion of this course, students will be able to – 

 

7ME4-21.1 Discuss the basic features of an analysis package. 

7ME4-21.2 
Demonstrate the deflection of beams subjected to point, uniformly distributed 
and varying loads 

 

7ME4-21.3 
Use the modern tools to formulate and solve problems of bars, truss, beams, and 

plate to find stress with different loading conditions. 

7ME4-21.4 
Applying basic principle to solve and demonstrate 1D and 2D heat transfer with 
conduction and convection boundary conditions. 

 
LO-PO-PSO MAPPING MATRIX OF COURSE 

 

LO/PO/PSO PO1 PO2 PO3 PO4 PO5 PO6 PO7 PO8 PO9 PO10 PO11 PO12 PSO1 PSO2 PSO3 

7ME4-21.1 3 - - - - - - - - - - 2 - 3 2 

7ME4-21.2 - 3 - - - - - - - - - 2 - 3 2 

7ME4-21.3 - - - - 3 - - - - - - 2 - 3 2 

7ME4-21.4 - - - 3 - - - - - - - 2 - 3 2 

 
PROGRAM OUTCOMES (POs) 

 

 
PO1 

Engineering   knowledge   : Apply   the knowledge   of mathematics, science, 

engineering fundamentals, and an engineering specialization to the solution of 

complex engineering problems 

 
PO2 

Problem analysis: Identify, formulate, review research literature, and analyze 

complex engineering problems reaching substantiated conclusions using first 

principles of mathematics, natural sciences, and engineering sciences. 

 

 
PO3 

Design/development of solutions: Design solutions for complex engineering 

problems and design system components or processes that meet the specified needs 

with appropriate consideration for the public health and safety, and the cultural, 

societal, and environmental considerations. 

 
PO4 

Conduct investigations of complex problems: Use research-based knowledge and 

research methods including design of experiments, analysis and interpretation of 

data, and synthesis of the information to provide valid conclusions. 

PO5 Modern tool usage: Create, select, and apply appropriate techniques, resources, and 
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 modern engineering and IT tools including prediction and modeling to complex 

engineering activities with an understanding of the limitations. 

 
PO6 

The engineer and society: Apply reasoning informed by the contextual knowledge to 

assess societal, health, safety, legal and cultural issues and the consequent 

responsibilities relevant to the professional engineering practice. 

 
PO7 

Environment and sustainability: Understand the impact of the professional 

engineering solutions in societal and environmental contexts, and demonstrate the 

knowledge of, and need for sustainable development. 

PO8 
Ethics: Apply ethical principles and commit to professional ethics and 

responsibilities and norms of the engineering practice. 

PO9 
Individual and team work: Function effectively as an individual, and as a member 

or leader in diverse teams, and in multidisciplinary settings. 

 

 
PO10 

Communication: Communicate effectively on complex engineering activities with 

the engineering community and with society at large, such as, being able to 

comprehend and write effective reports and design documentation, make effective 

presentations, and give and receive clear instructions. 

 

 
PO11 

Project management and finance: Demonstrate knowledge and understanding of 

the engineering and management principles and apply these to one’s own work, as a 

member and leader in a team, to manage projects and in multidisciplinary 

environments. 

 
PO12 

Life-long learning: Recognize the need for, and have the preparation and ability to 

engage in independent and life-long learning in the broadest context of technological 

change. 

 

 

PROGRAM SPECIFIC OUTCOMES (PSOs) 
 

 

PSO1 
Design, analyze and innovate solutions to technical issues in Thermal, Production 

and Design Engineering. 

PSO2 
Exhibit the knowledge and skills in the field of Mechanical & Allied engineering 

concepts. 

PSO3 Apply the knowledge of skills in HVAC&R and Automobile engineering. 
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Laboratory Evaluation Rubrics: 

RUBRICS FOR LAB 

 
S. 

No. 

Crit 

eria 

Sub Criteria and Marks Distribution  
Outstanding (>90%) 

 
Admirable (70-90%) 

 
Average (40-69%) 

 
Inadequate (<40%) 

Mid-Term End-Team 
Continues 

Evaluation 

 

 

 

 

 

 

 

 

A 

 

P
E

R
F

O
R

M
A

N
C

E
 (

P
O

1
, 

P
O

8
, 
P

O
9

) 

 
Procedure 

Followed 

 

M.M. 50 = 3 

M.M. 75 = 4 

M.M. 100 = 6 

 
Procedure 

Followed 

 

M.M. 50 = 3 

M.M. 75 = 4 

M.M. 100 = 6 

 
Procedure 

Followed 

 

M.M. 50 = 1 

M.M. 75 = 2 

M.M. 100 = 2 

 All possible system and Input/ 

Output variables are taken into 

account 

 Performance measures are 

properly defined 

 Experimental scenarios are 

very well defined 

 Most of the system and 

Input/ Output variables are 

taken into account 

 Most of the Performance 

measures are properly 

defined 

 Experimental scenarios 
are defined correctly 

 Some of the system and Input/ 

Output variables are taken into 

account 

 Some of the Performance 

measures are properly defined 

 Experimental scenarios are 

defined but not sufficient 

 
 System and Input/ Output 

variables are not defined 

 Performance measures are not 

properly defined  Experimental 

scenarios not defined 

Individual/Tea 

m Work 

 

M.M. 50 = 3 

M.M. 75 =4 
M.M. 100 = 6 

Individual/Tea 

m Work 

 

M.M. 50 = 3 

M.M. 75 =4 
M.M. 100 = 6 

Individual/Tea 

m Work 

 

M.M. 50 = 1 

M.M. 75 = 2 
M.M. 100 = 2 

 
 Coordination among the group 

members in performing the 

experiment was excellent 

 

 Coordination among the 

group members in 

performing the experiment 

was good 

 
 Coordination among the group 

members in performing the 

experiment was average 

 
 Coordination among the group 

members in performing the 

experiment was very poor 

Precision in 

data collection 

 

M.M. 50 = 3 

M.M. 75 = 4 
M.M. 100 = 6 

Precision in 

data collection 

 

M.M. 50 = 3 

M.M. 75 = 4 
M.M. 100 = 6 

Precision in 

data collection 

 

M.M. 50 = 2 

M.M. 75 = 2 
M.M. 100 = 4 

 
 Data collected is correct in 

size and from the experiment 

performed 

 
 Data collected is 

appropriate in size and but 

not from proper sources. 

 
 Data collected is not so 

appropriate in size and but from 

proper sources. 

 
ta collected is neither 

appropriate in size and norfrom 

proper sources 

 

 

 

 

 
B 

L
A

B
 R

E
C

O
R

D
/W

R
IT

T
E

N
 

W
O

R
K

 
(P

O
1

, 
P

O
8

, 
P

O
1
0

)  

 

NA 

 

 

NA 

Timing of 

Evaluation of 

Experiment 
 

M.M. 50 = 3 

M.M. 75 = 4 
M.M. 100 = 6 

 

 
 On the Same Date of 

Performance 

 

 
 On the Next Turn from 

Performance 

 

 
 Before Dead Line 

 

 

n the Dead Line 

Data Analysis 
 

M.M. 50 = 3 

M.M. 75 =5 
M.M. 100 = 6 

Data Analysis 
 

M.M. 50 = 3 

M.M. 75 =5 
M.M. 100 = 6 

Data Analysis 
 

M.M. 50 = 2 

M.M. 75 = 3 
M.M. 100 = 4 

 

 Data collected is exhaustively 

analyzed & appropriate features 

are selected 

 

 Data collected is analyzed 

& but appropriate features 

are not selected 

 

 Data collected is not analyzed 

properly. Features selected are 

not appropriate 

 

ta collected is not 

analyzed & the features 

are not selected 
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Results and 

Discussion 

 

M.M. 50 = 3 

M.M. 75 =5 

M.M. 100 = 6 

 

 
Results and 

Discussion 

 

M.M. 50 = 3 

M.M. 75 =5 

M.M. 100 = 6 

 

 
Results and 

Discussion 

 

M.M. 50 = 2 

M.M. 75 = 3 

M.M. 100 = 4 

 All results are very well 

presented with all variables 

 Well prepared neat 

diagrams/plots/ tables for all 

performance measured 

 Discussed critically behavior 

of the system with reference to 

performance measures 

 Very well discussed pros n 

cons of outcome 

 All results presented but 

not all variables mentioned 

 Prepared diagrams /plots/ 

tables for all performance 

measured but not so neat 

 Discussed behavior of the 

system with reference to 

performance measures but 

not critical 

 Discussed pros n cons of 

outcome in brief 

 Partial results are included 

 Prepared diagrams /plots/ 

tables partially for the 

performance measures 

 Behavior of the system with 

reference to performance 

measures has been superficially 

presented 

 Discussed pros n cons of 

outcome but not so relevant 

 

 Results are included but not as 

per experimental scenarios 

 No proper diagrams /plots/ 

tables are prepared 

 Behavior of the system with 

reference to performance 

measures has not been presented 

 Did not discuss pros n cons of 

outcome 

 

 

 

 

 

C 

 

V
IV

A
 (

P
O

1
, 

P
O

1
0

) 

Way of 

presentation 

 

M.M. 50 = 2.5 

M.M. 75 = 4 
M.M. 100 = 5 

Way of 

presentation 

 

M.M. 50 = 2.5 

M.M. 75 = 4 
M.M. 100 = 5 

Way of 

presentation 

 

M.M. 50 = 2 

M.M. 75 = 3 
M.M. 100 = 4 

 

 
 Presentation was very good 

 

 
 Presentation was good 

 

 
 Presentation was satisfactory 

 

 
 Presentation was poor 

Concept 

Explanation 

 

M.M. 50 = 2.5 

M.M. 75 = 4 
M.M. 100 = 5 

Concept 

Explanation 

 

M.M. 50 = 2.5 

M.M. 75 = 4 
M.M. 100 = 5 

Concept 

Explanation 

 

M.M. 50 = 2 

M.M. 75 = 3 
M.M. 100 = 4 

 

 Conceptual explanation was 

excellent 

 

 Conceptual explanation 

was good 

 

 Conceptual explanation was 

somewhat good 

 

 Conceptual explanation was 

Poor 

 

 
D 

A
T

T
E

N
D

A
 

N
C

E
 

 

 
NA 

 

 
NA 

Attendance 

 

M.M. 50 = 5 

M.M. 75 =8 

M.M. 100 =10 

 

 Present more than 90% of lab 

sessions 

 

 Present more than 75% of 

lab sessions 

 

 Present more than 60% of lab 

sessions 

 

 Present in less than 60% lab 

sessions 
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LAB CONDUCTION PLAN 

Total number of Experiment – 09 

Total number of turns required - 10 

Number of turns required for:- 

 

Experiment Number Scheduled 

Week 

Experiment -1 Week 1 

Experiment -2 Week 2 

Experiment -3 Week 3 

Experiment -4 Week 4 

Experiment -5 Week 5 

I Mid Term Week 6 

Experiment -6 Week 7 

Experiment-7 Week 8 

Experiment-8 Week 9 

Experiment-9 Week 10 

II Mid Term Week 11 

 

DISTRIBUTION OF LAB HOURS 
 

 

S. No. 

 

Activity 
Distribution of Lab Hours 

Time 

(180 minute) 

Time 

(120 minute) 

1 Attendance 5 5 

2 Explanation of Experiment & Logic 30 30 

3 Performing the Experiment 60 30 

4 File Checking 40 20 

5 Viva/Quiz 30 20 

6 Solving of Queries 15 15 
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GENERAL LAB INSTRUCTIONS 

DO’S 

1. Enter the lab on time and leave at proper time. 

2. Feel that practical are essentials to lay the foundation for understanding the subject. 

3. Have knowledge of the theoretical background of each experiment. 

4. Handling every equipment carefully. 

5. Consult your teacher, or your friend who had already done the experiment before entering the 

lab. This will help you to overcome difficulties while doing the experiments. 

6. Turn off the machines before leaving the lab unless a member of lab staff has specifically told 

you not to do so. 

7. Make as many observations/readings as possible. Large number of data will eliminate random 

errors and systematic errors. 

8. Calculations must be done meticulously. For this, the knowledge of using calculators and 

mathematical tables is essential. 

9. If you get wrong result others than the expected one, study your observation thoroughly and find 

out where you went wrong. Repeat the experiment until you get the correct observation, leading 

to the correct and expected result. 

10. If you notice any problem with machine/ equipment/tool, then please report it to lab staff 

immediately. Do not attempt to fix the problem yourself. 

DON’TS 

1. Don’t neglect the importance of practical. 

2. Don’t be lazy in making observation. Avoid copying someone else’s observation. 

3. There should not be any distraction. Don’t play with your friend or the apparatus while doing 

the experiment. 

4. Don’t damage the equipment. 

5. Don’t touch the moving parts of the machine. 

6. Don’t play with electric instruments. 

7. If you are going to be away from your machine for more than 10 or 15 minutes, switch off before 

leaving. This is for the security of your experiment and to ensure that others are able to use the 

lab resources while you are not. 

8. No food or soft drink is allowed in the lab or near any of the equipment. Aside from the fact that 

it leaves a mess and attract pests. If you need to eat or drink, take a break and do so in the 

canteen. 
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9. Do not work in a laboratory wearing loose hair, loose clothing or dangling jewelry. 

10. Don’t wear rings, watches, bracelets or other jewelry that could get could get caught in moving 

machinery. 

11. Do not eat food, drink beverages or chew gum in the laboratory. 

12. Don’t bring any external material in the lab, except your lab record, copy and books. 

 

 

LAB SPECIFIC SAFETY RULES 

1. Always sit to in front of your specified system. 

2. Always Login via students login. 

3. Do not install anything on the system. 

4. Do not delete anything from the system. 

5. Take all your files to your pend rive or on your E-mail. 
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Experiment No.1- Introduction to ANSYS Workbench 
 

Objective: - Introduction of GUI of the software in the areas of Mechanics of Solids, Vibration & Heat 

Transfer. 
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ANSYS Interface 

There are two methods to use ANSYS; Graphical Interface and Command File Coding. The graphical user 

interface or GUI follows the conventions of Windows based programs. This method is probably the best 

approach for new users. The command approach is used by professional users. It has the advantage that an 

entire analysis can be described in a small text file, typically in less than 50 lines of commands. This 

approach enables easy model modifications and minimal file space requirements. In this lab manual we 

mainly use the GUI. However, in some cases both the GUI and command code are used to show that how 

command code could be easy to use. 

 

• What is ANSYS Workbench? 

– ANSYS Workbench is a new-generation solution from ANSYS that provides powerful methods for interacting 

with the ANSYS solver functionality. This environment provides a unique integration with CAD systems, 

and your design process, enabling the best CAE results. 

 

• ANSYS Workbench is comprised of five modules: 

– Simulation for performing structural and thermal analyses using the ANSYS solver 

– CFX-Mesh for generating a CFX-Pre mesh for the CFX-5 solver 

– DesignModeler for creating and modifying CAD geometry to prepare the solid model for use in 

Simulation or CFX-Mesh 

–  DesignXplorer and DesignXplorer VT for investigating the effect of variations input to the response of 

the system 

– FE Modeler for translating a Nastran mesh for use in ANSYS 

 
• Analysis types available in Simulation:† 

– Linear Stress: Determines deflections, stresses, factors of safety, etc. based on standard strength of materials 

concepts under static loading. 

– Modal: Determines natural frequencies of a system (free vibration), including the effects of loading on a pre- 

stressed structure. 

– Heat Transfer: Steady-state thermal analyses to solve for temperature field and heat flux. Temperature- 

dependent conductivity and convection allowed. Thermal-stress analysis supported as well. 

– Harmonic: Determines structural response of system under sinusoidal excitation as a function of frequency. 

– Linear Buckling: Determines failure load or safety factor for buckling and its buckling mode shapes. 

– Shape Optimization: Indicates areas of possible volume reduction based on load paths through the part using 

Topological Optimization technology. 
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– Nonlinear Structural: Calculates deflections and stresses of system under static loading, accounting for large 

deflection effects, plasticity, and contact nonlinearities. 

 
 

START THE FE SOFTWARE ANSYS: 

 

ANSYS Workbench: This is a brand new GUI with an emphasis on CAD connectivity, ease of use, and easy 

management of assembly contact. This GUI is covered in a separate guideline. 

Launch Workbench in Windows via “Start Menu > Programs > ANSYS 14.5 > ANSYS Workbench” 

 
Starting ANSYS Workbench 

 

Preprocessor (Setting up the Model) 
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Interface of ANSYS Workbench 

 

VIEW TOOL BAR 
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Drag-and-drop the Static Structural module to create a new analysis. 
 

 

 

 

 

 

 

 

 

 

 

 

 

Engineering Data 

Use the Engineering Data cell with Mechanical systems or the Engineering Data component system to define 

or access material models for use in an analysis. Double-click the Engineering Data cell, or right mouse click 

and choose Edit from the context menu to display the Engineering Data workspace to define material data. 

 

Geometry 

Use the Geometry cell to import, create, edit or update the geometry model used for analysis. Right mouse 

click to display the context menu to access these functions. The right mouse button options are context 

sensitive and will change as the state of your geometry changes. All geometry-specific options are described 

here; not all will be available at all times. 

 

Model/Mesh 

The Model cell in the Mechanical application analysis systems or the Mechanical Model component system 

is associated with the Model branch in the Mechanical application and affects the definition of the geometry, 

coordinate systems, connections and mesh branches of the model definition. The Mesh cell in Fluid Flow 

analysis systems or the 

Mesh component system is used to create a mesh using the Meshing application. It can also be used to import 

an existing mesh file. 
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Setup 

Use the Setup cell to launch the appropriate application for that system. You will define your loads, boundary 

conditions, and otherwise configure your analysis in the application. The data from the application will then 

be incorporated in the project in ANSYS Workbench, including connections between systems. 

 

Solution 

From the Solution cell, you can access the Solution branch of your application, and you can share solution 

data with other downstream systems (for instance, you can specify the solution from one analysis as input 

conditions to another analysis). If you have an analysis running as a remote process, you will see the Solution 

cell in a pending state until the remote process completes. 

 

Results 

The Results cell indicates the availability and status of the analysis results (commonly referred to as post- 

processing). From the Results cell, you cannot share data with any other system. 

 
 

Design Modeler 

If instead of importing the geometry from another code or from another problem defined in the same 

workbench we decide to create a new geometry, clicking on NEW GEOMETRY will launch the designing 

modeler. 

 

Build the Geometry Using Design Modeler Module 

 

To begin; drag the Static Structural Module from the Analysis Systems toolbox and drop into the Project 

Schematic and double click on the Geometry sub module to open the DesignModeler. When asked, choose 

the desired unit system. 

 

Choose Create → Primitives → Box from the main menu to create a beam by entering the desired 

dimensions in the Details box. Hit the Generate button to actually create the geometry. 

 

When specifying the dimension of the beam, make sure that the origin of the coordinate system is located on 

the center of the beam’s cross section. The beam axis must be oriented along the global x-axis. 
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The beam on the Design Modeler 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

Note that ANSYS Workbench saves the model automatically; you can simply close Design Modeler now 

and continue with the next step. 

 
 

Define Units:- Units Menu Use this menu to select the Units system you want to use. 



Poornima College of Engineering, Jaipur Department of Mechanical Engineering 

10 

FEA LAB (7ME4-21) Manual 2021-22 

 

 

 

 
 

Material Properties 

1. Define Material Properties Materials define the mechanical behavior of the FE model. We will use a 

simple linear- elastic, isotropic material model. In the project schematic, right click on Engineering Data to 

open a context menu and choose Edit… 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Edit engineering data 

Enter a name for your new material in row 4 
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Naming the new material 

 

Choose the simplest available material model by dragging the item Isotropic Elasticity from the Toolbox 

and dropping it onto the row with your newly defined material. Isotropic Elasticity requires certain material 

parameters: Young’s Modulus and Poisson’s Ratio. 

After you entering the appropriate parameters do not forget to push Return to Project button and to update 

the project. 

 
 

Meshing To mesh the solid body select double click the Model sub-module in the Project schematic to open 

the Mechanical module. 
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Starting the meshing and analysis module 

 

Right click on Mesh in the Structure Tree and select a meshing method Mesh (right click) Insert Mapped 

Mesh 

 

At this point focus on the Details box and select the geometry (all 6 faces) and do not forget to update the 

project; then click the Generate button. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Meshed body 
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Applying Loads and Boundary Conditions 

Boundary Conditions To setup the necessary support: Structure Tree Static-Mechanic (right click)  
Insert Fixed Support Select the Face you want to assign as a fixed support. In the same way apply the 

load. 
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Solving 

To solve the problem add some solving tools to the Solution node which is part of the Structure tree. 

Solution (right click) Total Deformation 

Solution (right click) Total Strain 
Solution (right click) Total Stress 

Click Solve 
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ANSYS Files 

• There are various types of files used by Workbench, each differentiated by the file extension: 

– .wbdb: Workbench Project database, which keeps track of all of the different types of Workbench 

databases in a “Project” 

– .dsdb: Simulation database, which has all the information necessary to perform a structural or 

thermal analysis in Simulation 

– .agdb: DesignModeler database, containing geometry data for use with Simulation or CFX-Mesh 

– .dxdb: DesignXplorer/DesignXplorer VT database, which investigate relationships between input 

and output parameters 

– .cmdb: CFX-Mesh database, containing a mesh prepared for import to CFX-Pre and to be solved 

with CFX-5 

– .fedb: FE Modeler database, which has mesh information from a Nastran or Simulation model, used 

to convert to ANSYS 
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Viva Questions 

1. What do you mean by GUI? 

2. What are the File extensions used in ANSYS? 

3. What are different modes of analysis possible in ANSYS? 

4. What is meant by finite element? 

5. What are the steps involved in FEA? 

6. What is meant by finite element analysis? 

7. Mention some application of FEA 

8. What are the packages available for FEA 

9. Difference between FEA and FEM? 

10. What is the current ANSYS VERSION? 
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Experiment No.2 Structural Analysis of a Cantilever Beam 
 
 

The objective of this problem is to demonstrate a simple ANSYS Workbench problem with a textbook 

solution: finding Von Mises’ stresses and total deflection throughout the beam. This is a simple, single load 

step, structural analysis of a cantilever beam. The left side of the cantilever beam is fixed while there is a 

distributed load of 20N/m. 

Given Data:- 

L =110m Length of beam 

b =10m   Cross Section Base 

h =1 m Cross Section Height 

w=20N/m Distributed Load 

E=70GPa Young’s Modulus of Aluminum at Room Temperature 

μ =0.33 Poisson’s Ratio of Aluminum 

 
 

(1)  Von Mises Stress 
 

 
Assuming plane stress, the Von Mises Equivalent Stress can be expressed as: 

 

(i) 

Additionally, since the nodes of choice are located at the top surface of the beam, the shear stress at this 

location is zero. 

 

Using these simplifications, the Von Mises Equivalent Stress from equation (i) reduces to: 
 

 

Bending Stress is given by: 
 

 

(ii) 

 

 

(iii) 

 

 

 
(iv) 
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(2)  Beam Deflection 
 

 

 
 

 
Workbench Analysis System 

 
 

Opening Workbench  

1. On your Windows 7 Desktop click the Start button. 

2. Under Search Programs and Files type “ANSYS” 

3. Click on ANSYS Workbench to start workbench. This step may take time. 

 
 

Static Structural Analysis 

1. As you open ANSYS you can see the entire array of problems on the left had side this software can help 

you solve. The problem at hand is a Static Structural problem. Double click Static Structural (ANSYS) to 

open the task manager for your problem set in the Project Schematic area. 

2. ANSYS allows you to build on each problem, so it is smart to name each project. At the bottom of the task 

manager you will see Static Structural (ANSYS), double click this to change the name. For this problem 

choose “3D Cantilever beam.” 
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Engineering Data 

To begin setup for your cantilever beam, double click or right click on Engineering Data and click edit. 

This will bring up another screen. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

This new window will allow you to alter the material properties of your cantilever beam. Under Outline of 

Schematic A2: Engineering Data, it shows click here to add a new material, this menu allows you to input 

the material of your cantilever beam, double click and type Aluminum. 
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Double click on Isotropic Elasticity to give the material the same properties across the beam. This action 

brought up a new table on the right; this allows us to add necessary properties. As show on the top right of 

the screen in Table of Properties Row 2: Isotropic Elasticity: 

1. Click in Temperature and type 25 

2. Click in Young’s Modulus and type 70E9 or 7E10 

3. Click in Poisson’s Ratio and type 0.33 

4. Make sure to DELETE the Temperature entry after property input before continuing! Failure to do so will 

lead to errors later. 

 

 

 

 

 

 

 

 

After filling in the properties, this concludes the Engineering Data, to return to the project schematic area, 

click on   seen on the upper tab. 

Geometry  

Base Geometry 

1. Go to Workbench -> Project Schematic -> Geometry and double click. This will open a new window for 

ANSYS Design Modeler where the Geometry will be created. 
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Note: Select meters and hit ok 

2. In the new window, click the Display Plane icon to toggle the coordinate system. 

3. Go to Design Modeler > Tree Outline > right click on YZPlane. Click Look At to view the YZ plane. 

4. Go to Design Modeler -> Tree Outline -> Sketching 

5. Click on Rectangle and Click off Auto-Fillet: 

6. Bring your cursor into the workspace at point 0,0, over the origin until ‘P’ appears directly above the 

origin. 

7. Click on the origin to place the lower left corner of our rectangle on the origin. 

8. Click on a point in the first quadrant to define the top right corner of our rectangle. The point is arbitrary 

as we will be fixing dimensions momentarily. 

 

 

 

 

 

 

 

 

 

 

 

 

9. Go to Sketching Toolboxes -> Dimensions 

10. Click Horizontal to specify a horizontal dimension. 

11. Click the left and right faces of the rectangle in the sketch to specify that we will be dimensioning this 

horizontal length. A green line with a symbol should appear. 

12. Drag the green line above the sketch and click to set its location. 

13. Go to Detail View -> Dimension 1. In the first subcategory, replace the current dimension with 10. The 

units should populate automatically. 
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14. Go to Sketching Toolboxes -> Dimensions -> Vertical to specify the vertical dimension. 

15. Click the bottom and top faces of the sketch to specify the vertical dimension. A green line should appear. 

16. Drag the green line to the right of the sketch and click. 

17. Go to Detail View -> Dimension 2. Replace the value with 10. The units should populate automatically 

(meters). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Now that we have modeled the base geometry, we will extrude it to create a 3D volume. 
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3. Go to Design Modeler -> Generate. 

4. To verify our geometry, look at the isometric view. Click the blue dot in the triad in the lower right corner 

of the screen to look at the isometric view. 

Extrude Sketch 

 
1. Go to Main Toolbar -> and select Extrude 

2. Go to Modeling -> FD1, Depth (>0) -> enter in 110 
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Now that we have the geometry, we will mesh the beam using 3D Elements. 

Model 

Open ANSYS Mechanical 

1. out of Design Modeler. Don’t worry, your work will be saved. 

2. Go to Workbench -> Project Schematic -> Model This will open ANSYS Mechanical 

 

  
 

 

 

Material Assignment 

1. Go to Mechanical -> Outline -> Project -> Model -> Geometry -> Solid Body 

2. Under Mechanical -> Details of “SolidvBody” -> Material -> Assignment, change Structural Steel to 

Aluminum. 
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.5 m. This will give us 2 elements through the thickness of the beam. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

Mesh 

1. Go to Mechanical -> Outline -> Project -> Model -> Mesh 

2. Go to Mechanical -> Details of ‘Mesh’ -> Sizing -> Element Size and change the value from Default to 
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Setup 

You can perform the rest of your analysis for this problem in the ANSYS Mechanical window. 

The other options in the Workbench window will link you back to the same screen (i.e. Setup, 

Solution, Results) 

3. Click Mechanical ->Update. This may take some time. Your mesh should look as shown below: 
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Fixed Support 

1. Go to Mechanical -> Outline -> right click Static Structural (A5) 

2. Go to Insert -> Fixed Support 

We are going to fix the elements at the left end of the beam. In order to do this, we will use the         

Edge tool to select the left edge. However, from the current orientation of the beam, it is difficult to 

select this surface. 

3. Using the   Rotate tool click on the graphic area and move the mouse to the right. This will cause the 

left end of the beam to be oriented in a manner that can be clicked 
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4. Using the   Pan tool, click the graphic area and drag the left face to the center of the graphic window. 

Use the mouse scroll to zoom in on the left face. 

5. Click the  Edge tool. 

6. Go to Mechanical -> Outline -> Static Structural (A5) -> Fixed Support 

7. Run the cursor across the left end face. When it becomes red, click it to select it. 

8. Go to Mechanical -> Details of “Fixed Support” -> Geometry and select Apply 

While in the Project Schematic double click Setup This will open a new window similar to Model Space 

 
 

Loads 
 

 

1. Click the x-axis icon to get a side view of the cantilever beam 
 

2. Click Fixed end On the tool bar, make sure vertex option is selected. 

3. Go to Mechanical -> Outline -> Static Structural (A5) -> Fixed Support 

4. Run the cursor across the left end face. When it becomes red, click it to select it. 

5. Click the left side of the geometry; this will add a green box to select the point. 

6. Right click 
 

7. Click insert, and 

8. This will add a fixed end to your cantilever beam in the work space. 

10. Right click  

11. click insert , and A table will appear “Details of Force” 

-2200 (as distributed load) 

14. This will show your cantilever beam with a load applied as shown. Leave the Setup screen open this time. 
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Equivalent Stress  

Go to Mechanical -> Outline -> Project -> Model(A4) -> Static Structural (A5) -> Solution (A6) -> 

Insert -> Stress -> Equivalent (Von Mises) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Solution 

Deformation Go to Mechanical -> Outline -> Project -> Model(A4) -> Static Structural (A5) -> Solution 

(A6) -> Insert -> Deformation -> Total 
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Now that our solvers have been defined, go to Mechanical ->  Solve. The calculations in Workbench 

may take up to a minute to solve. 

 

Your Stress plot should look as shown below: 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Go to Mechanical -> Outline -> Project -> Model(A4) -> Solution(A6) -> Total Deformation 

Your Von-Mises plot should look as shown below: 
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Results:- 

Max Deformation According to equation, the theoretical max deflection is 7.6 mm. By Ansys it is 6.1 mm. 

Equivalent Von Mises Stress, theoretically we got 66 KPa and by Ansys we have 76.5 Kpa. The difference is 

due to Meshing & discritization in Ansys as we have not done theoretical solution 

 

 

Viva Questions:- 

1. What is point load (P)? 

2. What is meant by plane stress? 

3. Define plane strain. 

4. What are isotropic and orthotropic materials? 

5. Define term element 

6. What do you mean by cantilever beam? 

7. Define Young’s Modulus and Poisson’s Ratio. 

8. What is factor of safety? 

9. What is bending moment diagram? 

10. What is shear force diagram? 
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Experiment No.3 Steady State Thermal Analysis 
 

Objective:- Steady State Thermal Analysis by using ANSYS workbench. A steady-state thermal analysis 

calculates the effects of steady thermal loads on a system or component. You can use steady-state thermal analysis 

to determine temperatures, thermal gradients, heat flow rates, and heat fluxes in an object that are caused by 

thermal loads that do not vary over time. Such loads include the following: 

 Convections 

 Radiation 

 Heat flow rates 

 Heat fluxes (heat flow per unit area) 

 Heat generation rates (heat flow per unit volume) 

 Constant temperature boundaries. 

A steady-state thermal analysis may be either linear, with constant material properties; or nonlinear, with material 

properties that depend on temperature. The thermal properties of most material do vary with temperature, so the 

analysis usually is nonlinear. Including radiation effects also makes the analysis nonlinear. 

 

Problem Description:- Steady state thermal analysis of “car brake disc” by using the given below parameters & 

sketch. 

Parameters:- Thermal Material: Aluminum (from Engineering data of Ansys) 
 

Sketch:- (by using revolve option) 
 

 

 

 

 

 

 

 

 

 

 

 

 
Roll No 1. Dimension 2. Dimension 3. Dimension 

1-6-11-16-21-26-31-36-41-46-56-61-66-71 50 100 150 

2-7-12-17-22-27-32-37-42-47-57-62-67-72 51 101 151 

3-8-13-18-23-28-33-38-43-48-58-63-68-73 52 102 152 

4-9-14-19-24-29-34-39-44-49-59-64-69-74 53 103 153 

5-10-15-20-25-30-35-40-45-50-60-65-70-75 54 106 156 
 

Result:- 1. Maximum Temperature 2. Total Heat Flux 

 

Procedure:- 

Opening Workbench 

1.On your Windows 7 Desktop click the Start button. 

2.Under Search Programs and Files type “ANSYS” 

3.Click on ANSYS Workbench to start workbench. This step may take time. 
 

Static Structural Analysis 

1. As you open ANSYS you can see the entire array of problems on the left had side this software can help you 

solve. The problem at hand is a Thermal problem. Double click Steady State Thermal (ANSYS) to open the task 

manager for your problem set in the Project Schematic area. 
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2. ANSYS allows you to build on each problem, so it is smart to name each project. At the bottom of the task 

manager you will see Steady State Thermal (ANSYS), double click this to change the name. For this problem 

choose “Car Brake Disc.” 

 

Engineering Data 

To begin setup for your cantilever beam, double click or right click on Engineering Data and click edit. This will 

bring up another screen. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

This new window will allow you to alter the material properties of your cantilever beam. Under Outline of 

Schematic A2: Engineering Data, it shows click here to Thermal material, this menu allows you to input the 

material of your cantilever beam, add the material. 

2 

1 
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Click on + Sign and click on Filter engineering data 
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click on seen on the upper tab. 

 

Geometry  

Base Geometry 

1. Go to Workbench -> Project Schematic -> Geometry and double click. This will open a new window for 

ANSYS Design Modeler where the Geometry will be created. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: Select meters and hit ok 

2. In the new window, click the Display Plane icon to toggle the coordinate system. 
3. Go to Design Modeler > Tree Outline >right click on YZ Plane. Click Look At to view the YZ plane. 

4.Go to Design Modeler -> Tree Outline -> Sketching 
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7 
5 

 

 

 

 

 

 

9 

4 
8 6 

 
 
 
 
 
 
 

 

5. Click on Polyline. 

6. Bring your cursor into the workspace at point 0,0, over the origin until ‘P’ appears directly above the origin. 

7. Click on the origin to place the lower left corner. 
8. Click on a point in the first quadrant to define the top right corner of our rectangle. The point is arbitrary as we 

will be fixing dimensions momentarily. 

9. Draw the geometry as shown. 

Revolve Sketch 

1. Go to Main Toolbar ->and selectRevolve 

2. Go to Modeling -> FD1, Angle (>0) ->enter in360 

 

 

 

4 
3 

1 

 
 

2 
 
 

 
3. 

Choose Z axis as Axis and click Apply 
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4. Go to Design Modeler ->    Generate. 

5. To verify our geometry, look at the isometric view. Click the blue dot in the triad in the lower right corner of the 

screen to look at the isometric view. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Model 

Open ANSYS Mechanical 

1. out of Design Modeler. Don’t worry, your work will be saved. 
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Mesh 

1. Go to Mechanical -> Outline -> Project -> Model -> Mesh 

2. Go to Mechanical -> Details of ‘Mesh’ -> Sizing -> Element Size and change the value from Default to .5 m. 

This will give us 2 elements through the thickness of the beam. 

 

2. Go to Workbench -> Project Schematic -> Model This will open ANSYS Mechanical 

Material Assignment 

1. Go to Mechanical -> Outline -> Project -> Model -> Geometry -> Solid Body 

2. Under Mechanical -> Details of “Solid Body” -> Material -> Assignment, change Structural Steel to 

Aluminum. 
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3. Click Mechanical ->Update. This may take some time. Your mesh should look as shown below: 

Setup 

You can perform the rest of your analysis for this problem in the ANSYS Mechanical window. 

The other options in the Workbench window will link you back to the same screen (i.e. Setup, 

Solution, Results) 

 

Fixed Support 

1. Go to Mechanical -> Outline -> right click Steady State Thermal 

2. Go to Insert ->Temperature 
 

 

 

 

 

1 

2 
 
 
 
 
 
 
 
 
 
 

 

3. Under temperature select the lower face in geometry and select apply. 

4.Go to Temperature ->80 
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3 
1 

 

4 
 
 
 
 
 

 

5. Go to Mechanical -> Outline -> right click Steady State Thermal 

6. Go to Insert -> Convection 
 

 

 

 

 

 

 

 

5 
1 6 

1 
 
 
 
 
 
 
 
 
 
 
 

 

7. Under temperature select the middle face in geometry and select apply. 

8. Go to Film Coefficient (click on arrow mark) and select Import Convection Data, Select the Stagnant Air- 

Horizontal Cyl Radio Button. 
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Solution 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Solution->Insert->Thermal->Temprature 

1. Solution->Insert->Thermal->Thermal Flux 

Now that our solvers have been defined, go to Mechanical ->  Solve. The calculations in Workbench may take 

up to a minute to solve. 

Go to Mechanical -> Outline -> Project -> Model (A4) ->Solution (A6) -> Maximum 
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Temperature 

Your Temperature plot should look as shown below: 
 

 

Total Heat Flux 

Your 
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Viva Questions:- 

 
1. How u discretize a model? 

2. What is coefficient of thermal expansion? 

3. Mention different types of elements 

4. Define steady state analysis. 

5. Is stress depends on material property? 

6. What are the different types of analysis? 

7. Define mesh plotting 

8. What are the types of boundary conditions? 

 

 

Temperature plot should look as shown below: 
 

 

9. What is P-method and H-method? 

10. What do you mean by continuum? 
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Problem Specification:- 

Consider an aluminum beam that is clamped at one end, with the following dimensions. 

Experiment No.4. Cantilever Beam Modal Analysis 
 

Objective:- To find the Natural frequency & mode shapes of a cantilever beam 

• Modal analysis in structural mechanics is to determine the natural mode shapes and frequencies of an 

object or structure during free vibration. Modal analysis is used to determine a structure’s vibration 

characteristics — natural frequencies and mode shapes. 

• It is the most fundamental of all dynamic analysis types and is generally the starting point for other, more 

detailed dynamic analyses. 

• Modal analysis, or the mode-superposition method, is a linear dynamic-response procedure which 

evaluates and superimposes free-vibration mode shapes to characterize displacement patterns. Mode shapes 

describe the configurations into which a structure will naturally displace. Typically, lateral displacement 

patterns are of primary concern. Mode shapes of low-order mathematical expression tend to provide the 

greatest contribution to structural response. As orders increase, mode shapes contribute less, and are 

predicted less reliably. It is reasonable to truncate analysis when the number of mode shapes is sufficient. 

• A structure with N degrees of freedom will have N corresponding mode shapes. Each mode shape is an 

independent and normalized displacement pattern which may be amplified and superimposed to create a 

resultant displacement pattern. 

 

 

 

Length 4 m 

Width 0.346 m 

Height 0.346 m 

  

 
Roll No Length 

1-6-11-16-21-26-31-36-41-46-56-61-66-71 4 

2-7-12-17-22-27-32-37-42-47-57-62-67-72 4.5 

3-8-13-18-23-28-33-38-43-48-58-63-68-73 5 

4-9-14-19-24-29-34-39-44-49-59-64-69-74 5.5 

5-10-15-20-25-30-35-40-45-50-60-65-70-75 6 

The aluminum used for the beam has the following material properties. 

Density 2,700 kg/m^3 

Young’s Modulus 70x10^9 Pa 

Poisson Ratio 0.35 

Using ANSYS Workbench find the first six natural frequencies of the beam and the mode shapes. 

 

Results Required:- 1. Frequency tabular data 2. Mode shapes (6) 

https://en.wikipedia.org/wiki/Modal_analysis
https://en.wikipedia.org/wiki/Vibration
https://wiki.csiamerica.com/display/kb/Nonlinear
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Pre-Analysis & Start-Up:- 

Pre-Analysis 

The following equations give the frequencies of the modes and the mode shapes and are derived from Euler- 

Bernoulli Beam Theory. 
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In this section we will input the properties of aluminum (as defined in the the Problem Specification) in to ANSYS. 

First, double click Engineering Data, 

, in the "Cantilever Modal" Project. Next, click where it says "Click here to add a new material" 

as shown in the image below. 

 

Start ANSYS Workbench & Load Files 

In this section we will launch ANSYS Workbench and then load the project file, "cantilever.wbpj" that was created 

in the "Cantilever Beam" tutorial. 

Start > All Programs > ANSYS 16.0 > Workbench 

 

 

Rename Modal (ANSYS) 

Double click on Modal (ANSYS) and rename it to "Cantilever Modal". 
 

https://confluence.cornell.edu/display/SIMULATION/ANSYS%2B-%2BCantilever%2BBeam%2BModal%2BAnalysis
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Next, enter "Aluminum" and press enter. You should now have Aluminum listed as one of the materials in table 

called "Outline of Schematic B2: Engineering Data", as shown below. 
 
 

Then, (expand) Linear Elastic, as shown below. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Now, (Double Click) Isotropic Elasticity. Then set Young's Modulus to 70e9 Pa and set Poisson's Ratio to 0.35 , 

as shown below. 

 

Next, (expand) Physical Properties, as shown below. 
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Now, (Double Click) Density. Then, set Density to 2,700 kg / m^3 , as shown below. 

Now, the material properties for Aluminum have been specified. Lastly, (Click) Return To 

Project, . 

Save 

Save your project now and periodically, as you work. ANSYS does not have an auto-save feature. 

Go to Step 2: Geometry Create geometry as same as we have done in experiment no 3. 

Mesh 

Launch Mechanical 

 

 
 

 

(double click) Model, , in the "Cantilever Modal" project. 

 

Generate Default Mesh 

First, (click) Mesh in the tree outline. Next, (click) Mesh > Generate Mesh as shown below. 
 

https://confluence.cornell.edu/display/SIMULATION/Cantilever%2BBeam%2BModal%2BAnalysis%2B-%2BGeometry
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Physics Setup 

Size Mesh 

In this section we will size the mesh, such that it has ten uniform elements. In order to size the mesh, first 

expand Sizing located within the Relevance centre fine and Smoothing High 

 
 

Now, (click) Mesh > Generate Mesh in order to generate the new mesh. You should obtain the mesh that is shown 

in the following image. 
 

 

Material Assignment 

At this point, we will tell ANSYS to assign the Aluminium material properties that we specified earlier to the 

geometry. First, (expand) Geometry then (click) Line Body, as shown below. 
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At this point your "Details of Line Body" table, should look comparable to the following image. 

Then, (expand) Material in the "Details of Line Body" table and set Assignment to Aluminium, as shown below. 
 

Fixed Support 

First, (right click) Modal > Insert > Fixed Support, as shown below. 
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Next, click the vertex selection filter button, . Then, click on the left end of the beam and apply it as 

the Geometry in the "Details of Fixed Support" table. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Numerical Solution 

 
Specify Results (Deformation) 

Here, we will tell ANSYS to find the deformation for the first six modes. Then, we will be able to see the shapes of 

the six modes. Additionally, we will be able to watch nice animations of the six modes. 

Make sure that you set Mode to the respective mode number. At this point, your Outline should look the same as 

the following image. 
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Right click on Solution and evaluate all results 

 
Numerical Results 

 

Mode Shapes 
 

 

 

Mode 1 
 

In order to run the simulation and calculate the specified outputs, click the Solve button, 

Select all natural frequency and right click to solve for results. 

. 
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Mode 4 

Mode 5 

Mode 2 
 

 
 

Mode 3 
 

 
 

Mode 6 
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Viva Questions:-  

 

1. What is modal analysis? 

2. What is Natural frequency? 

3. How many natural frequencies and mode shapes can beam has? Why? 

4. How will you verify whether the simulation is correct? Explain methods. 

5. What do you mean by Degree of Freedom? 

6. What is the total degree of freedom of ANSYS commercial package? 

7. What is discretization? 

8. Mention different types of elastic constants. 

9. Specify the terms required to solve FEA problem. 

Verification & Validation 

For our verification, we will focus on the first 3 modes. ANSYS uses a different type of beam element to compute 

the modes and frequencies, which provides more accurate results for relatively short, stubby beams such as the one 

examined in this tutorial. However, for these beams, the Euler-Bernoulli beam theory breaks down and is no longer 

valid for higher order modes. 

 

Verification 

 
Comparison with Euler-Bernoulli Theory 

From our Pre-Analysis, based on Euler-Bernoulli beam theory, we calculated frequencies of 17.8, 111.5 and 312.1 

Hz for the first three bending modes. The ANSYS frequencies for the first three bending modes are 17.7, 107.0 and 

285.2 Hz. Note that in the ANSYS results, the third mode is NOT a bending mode. So the fourth mode reported by 

ANSYS is the third bending mode. These results give percent differences of 0.6%, 4.2% and 8.7% between 

ANSYS and theory. Thus the ANSYS results match quite well with Euler-Bernoulli beam theory. Note that the 

ANSYS beam element formulation used here is based on Timoshenko beam theory which includes shear- 

deformation effects (this is neglected in the Euler-Bernoulli beam theory). 
 

10. Define: Modulus of rigidity, Bulk modulus. 
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Experiment no-5 Comparison of Stress Concentrated Loads 
 
 

Opening Workbench 

1.On your Windows 7 Desktop click the Start button. 

2.Under Search Programs and Files type “ANSYS” 

3.Click on ANSYS Workbench to start workbench. This step may take time. 

 

Comparison of Stress Concentrated Loads 

1. As you open ANSYS you can see the entire array of problems on the left had side this software can help you 

solve. The problem at hand is a Static Structural problem. Double click Static Structural (ANSYS) to open the 

task manager for your problem set in the Project Schematic area. 

2. ANSYS allows you to build on each problem, so it is smart to name each project. At the bottom of the task 

manager you will see Static Structural (ANSYS), double click this to change the name. For this problem choose 

“3DCantilever beam.” 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

Engineering Data 

To begin setup for your cantilever beam, double click or right click on Engineering Data and click edit. This will 

bring up another screen. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

This new window will allow you to alter the material properties of your cantilever beam. Under Outline of 

Schematic A2: Engineering Data, it shows click here to add a new material, this menu allows you to input the 

material of your cantilever beam, double click and type Aluminum. 
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Double click on Isotropic Elasticity to give the material the same properties across the beam. This action brought 

up a new table on the right; this allows us to add necessary properties. As shown on the top right of the screen in 

Table of Properties Row 2: Isotropic Elasticity: 

1. Click in Temperature and type 25 

2. Click in Young’s Modulus and type 70E9 or 7E10 

3.Click in Poisson’s Ratio and type 0.33 

4. Make sure to DELETE the Temperature entry after property input before continuing! Failure to do so will lead to 

errors later. 
 

 

 

 

 

 

 

 

After filling in the properties, this concludes the Engineering Data, to return to the project schematic area, click on 

 seen on the upper tab. 

Geometry-GEOMETERY 1(Non Filleted) 

Base Geometry 
1. Go to Workbench -> Project Schematic -> Geometry and double click. This will open a new window for 

ANSYS Design Modeler where the Geometry will be created. 
 

 

 

 

 

 

 

 

 

 

 

 

 

2. Note: Select meters and hit ok 
3. In the new window, click the Display Plane icon to toggle the coordinate system. 

4. Go to Design Modeler > Tree Outline >right click on XY Plane. Click Look At to view the YZ plane. 

5. Go to Design Modeler -> Tree Outline -> Sketching 
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6. Click on Rectangle and Click off Auto-Fillet: 

7. Draw a rectangle by free hand. 

 

 
Give the geometry dimensions i.e. V2=50mm and H1=100mm. 

 

8. Extrude the geometry to the height=30mm. 

9. Select the Face Element or pressCtrl+F. 
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10. Select the longer face of the solid, and click on sketching. Draw another rectangle over the longer face and 

give dimensions V1=30mm and H2=70mm. 

11. Extrude the face at height 50mm. 
 

 

 

12. Close the Design Modeler and switch to the Model from Project Schematic. 
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14. Select Static Structural(Right Click)>>Insert>>Fixed Support. 

 

 
 

13. Select Mesh(right click)>>Generate Mesh. 
 

 

15. Choose the base as the fixed support and select apply. 

16. Select Static Structural(Right Click)>>Insert>>Force. 

17. Choose the top surface of the as geometry to apply. 
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18. Select the Magnitude and give it the value of 1000N. 

19. Give the direction as shown. 
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Choose Total Deformation and Max. Principle Stress from solver and click on SOLVE. 

20. Note the values of the Total Deformation=8.164x10-5and the value for Max. Principle Stress= 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

0.47258MPa at the meeting edges. 
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Geometry-GEOMETERY 2(Filleted) 

Base Geometry 

1. Go to Workbench -> Project Schematic -> Geometry and double click. This will open a new window for 

ANSYS Design Modeler where the Geometry will be created. 

 
2. Note: Select meters and hit ok 

3. In the new window, click the Display Plane icon to toggle the coordinate system. 

4. Go to Design Modeler > Tree Outline >right click on XY Plane. Click Look At to view the YZ plane. 

5. Go to Design Modeler -> Tree Outline -> Sketching 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

6. Click on Rectangle and Click off Auto-Fillet: 

7. Draw a rectangle by free hand. 
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8. Give the geometry dimensions i.e. V2=50mm and H1=100mm. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

9. Extrude the geometry to the height=30mm. 
 

10. Select the Face Element or press Ctrl+F. 

11. Select the longer face of the solid, and click on sketching. Draw another rectangle over the longer face and 

give dimensions V1=30mm and H2=70mm. 
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13. Now add a fillet over the meeting edges to the solid. 

 

 
12. Extrude the face at height 50mm. 
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14. Give the value of the filleted radius equal 3mm. 

 

 
15. Select the meeting edges and click generate. 

16. Close the Design Modeler and open MODEL. 

17. Select Static Structural(Right Click)>>Insert>>Fixed Support. 
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18. Choose the base as the fixed support and select apply. 



Poornima College of Engineering, Jaipur Department of Mechanical Engineering 

67 

FEA LAB (7ME4-21) Manual 2021-22 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

19. Select Static Structural (Right Click)>>Insert>>Force. 

20. Choose the top surface of the as geometry to apply. 

21. Select the Magnitude and give it the value of 1000N. 

22. Give the direction as shown. 
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23. Choose Total Deformation and Max. principle Stress from solver and click on SOLVE. 

24. Note the Values of Total Deformation=0.00024723 mm and that of Max. Principle Stress =1.5143MPa at 

the fillet point. 

Now compare both the values. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Sr. No. TOTAL DEFORMATION MAX. Principle Stress 

GEOMETERY 1 8.24x10-5 0.4258MPa. 

GEOMETERY 2 8.124x10-5 0.32577MPa. 
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Viva Questions:- 

 

1. What is Poisson’s ratio and its significance? 

2. What do u means by stress concentration & u mesh for such regions? 

3. What is shape function? 

4. How do verify and validate the results obtained from FEA? 

5. Are there any recommended commercial FEM packages that are versatile in handling a wide range of 

problems? 

6. What is optimization in ANSYS? 

7. What is Endurance limit? 

8. Define truss. 

9. Mention some common material properties. 

10. What is the purpose of meshing or dividing the component into finite elements? 
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Engineering Data 

To begin setup for your cantilever beam, double click or right click on Engineering Data and clickedit. This will 

bring up another screen. 

Experiment No.6 Analysis of Axis-Symmetric Solids 
 

Opening Workbench 

1.On your Windows 7 Desktop click the Start button. 

2.Under Search Programs and Files type “ANSYS” 

3.Click on ANSYS Workbench to start workbench. This step may take time. 
 

Analysis of Axis-Symmetric Solids 

1. As you open ANSYS you can see the entire array of problems on the left had side this software can help you 

solve. The problem at hand is a Static Structural problem. Double click Static Structural (ANSYS) to open the 

task manager for your problem set in the Project Schematic area. 

2. ANSYS allows you to build on each problem, so it is smart to name each project. At the bottom of the task 

manager you will see Static Structural (ANSYS), double click this to change the name. For this problem choose 

“3DCantilever beam.” 
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This new window will allow you to alter the material properties of your cantilever beam. Under Outline of 

Schematic A2: Engineering Data, it shows click here to add a new material, this menu allows you to input the 

material of your cantilever beam, double click and type Aluminum. 

Double click on Isotropic Elasticity to give the material the same properties across the beam. This action brought 

up a new table on the right; this allows us to add necessary properties. As show on the top right of the screen in 

Table of Properties Row 2: Isotropic Elasticity: 

1. Click in Temperature and type 25 

2. Click in Young’s Modulus and type 70E9 or 7E10 

3.Click in Poisson’s Ratio and type 0.33 

4. Make sure to DELETE the Temperature entry after property input before continuing! Failure to do so will lead to 

errors later. 
 

 

 

 

 

 

 
 

After filling in the properties, this concludes the Engineering Data, to return to the project schematic area, click on 

 seen on the upper tab. 

Geometry  

Base Geometry 

1. Go to Workbench -> Project Schematic -> Geometry and double click. This will open a new window for 
ANSYS Design Modeler where the Geometry will be created. 

 
2. Note: Select meters and hit ok 

3. In the new window, click the Display Plane icon to toggle the coordinate system. 

4. Go to Design Modeler > Tree Outline >right click on XY Plane. Click Look At to view the YZ plane. 
5. Go to Design Modeler -> Tree Outline -> Sketching 



Poornima College of Engineering, Jaipur Department of Mechanical Engineering 

73 

FEA LAB (7ME4-21) Manual 2021-22 

 

 

 

 
 

6. Click on Rectangle and Click off Auto-Fillet: 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

7. 
8. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Draw a rectangle taking origin into consideration. 

Give the dimensions to the rectangle, as V1=50 and H2=100. 
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9. Using symmetry constraint bring the intersection of the diagonals of the rectangle at the origin. 
 

 

10. Draw a circle of 35mm in the center of rectangle, or at the origin. 

NOTE: Now the generated drawing is axis-symmetric, hence the meshed model of the quarter will be equal to the 

four times the actual model. Hence to reduce calculations and to speed the work, axis-symmetric solids are used. 
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Remove any 3 quarters of the drawing, as it is axis-symmetric hence, will be similar to all the quarters. 

11. Extrude the model up to 10 mm. 
12. Close the Design Modeler and start Solver/MODEL. 
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13. Right click on Mesh>Generate Mesh 

14. 
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17. Select the Force from the Analysis Setting>Insert>Force 

18. Select the face as shown, the value of force as 100N and the direction as shown. 

 

 
 

15. Select the Fixed Support from the Analysis Setting>Insert>Fixed Support 

16. Select the face as shown below, and click on apply in detail pane. 
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SOLUTION:- 

Figure 1: Value of Total Deformation =0.0055555 mm(max) 

 

 
 

19. Select the Total Displacement, Maximum Principle Stress, and Maximum Principle Strain, and click on 

SOLVE. 

Figure 2: Value of Max. Principle Strain = 5.236 (max) 
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Viva Questions:- 

 

1. What is aspect ratio? 

2. Differentiate between global and local axes. 

3. What is the difference between linear and non-linear finite element analysis? 

4. What is the difference between static and dynamic FEA? 

5. What is the difference between implicit and explicit finite element analysis? 

6. What is the purpose of meshing or dividing the component into finite elements? 

7. When can we use symmetric boundary in the analysis? 

8. Explain force method and stiffness method? 

9. How do you compute strains and stresses in FEA? 

10. What are the types of boundary conditions? 

 

 
Figure 3: Value of Max. Principle Stress = 14.76 MPa 



Poornima College of Engineering, Jaipur Department of Mechanical Engineering 

80 

FEA LAB (7ME4-21) Manual 2021-22 

 

 

The pressure load P/A on the smaller cross-section is 1000 psi. 

Calculate the axial stress concentration factor and compare it to the formula 

 

Go to Step 1: Pre-Analysis & Start-Up 

Pre-Analysis & Start-Up 

Pre-Analysis 

Experiment No.7 Analysis of A Stepped Shaft in Axial Tension 

 

Problem Specification Consider a stepped shaft under an applied axial load, P. A stress concentration is apparent 

at the step where the cross-sectional area is discontinuous. The cross section is circular. 
 

So the problem becomes amenable, let’s consider a relatively small fillet placed at the step to reduce the stress 

concentration to a finite value. 
 

It is recommended that you make some back-of-the-envelope estimates of expected results before launching into 

your computer solution. Here 
 

for which the following formula for the axial stress concentration factor, K, holds (Roark’s Formulas for Stress and 

Strain, Warren C. Young and Richard G. Budynas, 2002): 

https://confluence.cornell.edu/pages/viewpage.action?pageId=220956095
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We'll compare the above axial stress concentration factor to the value obtained from ANSYS. 

 

Start-Up 

Launch ANSYS Workbench and start a "Static Structural" analysis 
 

 

 

 

 

 

 

 

 

 

 

 

Give the inputs for the materials, specifications and units 
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Go to Step 2: Geometry 

We'll first create a sketch and then a "surface body" from the sketch. The "surface body" is nothing but an area that 

we can mesh and apply boundary conditions to. 

https://confluence.cornell.edu/display/SIMULATION/Stepped%2BShaft%2B-%2BGeometry
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Mesh 

The following video shows how to create a mesh for the 2D geometry. We stick with the default "Q8" elements 

(eight nodes per element including mid-side nodes). The element edge sizes are controlled by inserting a "face 

sizing". 
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Physics Setup 

Specify the physics of the problem: axisymmetric approximation,  material properties (Young's modulus and 

Poisson ratio) and boundary conditions. 
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Poornima College of Engineering, Jaipur Department of Mechanical Engineering 

91 

FEA LAB (7ME4-21) Manual 2021-22 

 

 

Numerical Results 

Plot the deformed shape and use it to check if the boundary conditions (displacement constraints and point load) 

have been applied correctly. 

1. Total Deformation 

 
Plot the normal stress in the axial direction. The stress concentration factor can be deduced from this plot. 
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1. Normal Stress in Y-direction 
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Visualize the full 3D shape by revolving the 2D (axisymmetric) geometry about the axis. 
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Axial Stress Concentration Factor 

In the table below, the axial stress concentration factors on the original and refined meshes are compared with the 

hand calculation from the Pre-Analysis step. Recall that the hand calculation used a formula from Roark’s 

Formulas for Stress and Strain. 
 
 

ANSYS, Original mesh ANSYS, Refined mesh Hand calculation 

1.309 1.316 1.377 

There is only a slight change on refining the mesh. The stress concentration factor on either mesh is accurate to 

within the level of accuracy of the cited formula, i.e. 5%. This increases our confidence in the ANSYS results. 

https://confluence.cornell.edu/pages/viewpage.action?pageId=220956095
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Viva Questions:- 
 

1. What are the different menus in ANSYS? 

2. Give examples for the finite element. 

3. What is the history of the FEM? 

4. What are the three phases of finite element method? 

5. What is discretization? 

6. Explain the principle of virtual displacement. 

7. Mention some advantages of FEA over solid mechanics. 

8. What are the different types of errors in FEA? 

9. What is the difference between static and dynamic FEA? 

10. What is the difference between implicit and explicit finite element analysis? 
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Experiment no. 8- Introduction to MATLAB 
 

Objective: To introduce the basic information on MATLAB 

What Is MATLAB? 

MATLAB is a high-performance language for technical computing. It integrates computation, visualization, and 

programming in an easy-to-use environment where problems and solutions are expressed in familiar mathematical 

notation. Typical uses include: 

 
 Math and computation 

 Algorithm development 

 Modeling, simulation, and prototyping 

 Data analysis, exploration, and visualization 

 Scientific and engineering graphics 

 Application development, including Graphical User Interface building 

 
MATLAB is an interactive system whose basic data element is an array that does not require dimensioning. This 

allows you to solve many technical computing problems, especially those with matrix and vector formulations, in a 

fraction of the time it would take to write a program in a scalar non interactive language such as C or Fortran. 
 

The name MATLAB stands for matrix laboratory. MATLAB was originally written to provide easy access to 

matrix software developed by the LINPACK and EISPACK projects, which together represent the state-of-the-art 

in software for matrix computation. 
 

MATLAB has evolved over a period of years with input from many users. In university environments, it is the 

standard instructional tool for introductory and advanced courses in mathematics, engineering, and science. In 

industry, MATLAB is the tool of choice for high-productivity research, development, and analysis. 
 

MATLAB features a family of application-specific solutions called toolboxes. Very important to most users of 

MATLAB, toolboxes allow you to learn and apply specialized technology. Toolboxes are comprehensive 

collections of MATLAB functions (M-files) that extend the MATLAB environment to solve particular classes of 

problems. Areas in which toolboxes are available include signal processing, control systems, neural networks, 

fuzzy logic, wavelets, simulation, and many others. 
 

MATLAB is a fourth-generation programming language and numerical analysis environment. Uses for MATLAB 

include matrix calculations, developing and running algorithms, creating user interfaces (UI) and data visualization. 

The multi-paradigm numerical computing environment allows developers to interface with programs developed in 

different languages, which makes it possible to harness the unique strengths of each language for various purposes. 

 

MATLAB is used by engineers and scientists in many fields such as image and signal processing, communications, 

control systems for industry, smart grid design, robotics as well as computational finance. 

 

The MATLAB System:- MATLAB system consists of five main parts: 

 

The MATLAB language. 

This is a high-level matrix/array language with control flow statements, functions, data structures, input/output, and 

object-oriented programming features. It allows both "programming in the small" to rapidly create quick and dirty 

throw-away programs, and "programming in the large" to create complete large and complex application programs. 

 

The MATLAB working environment. 

This is the set of tools and facilities that you work with as the MATLAB user or programmer. It includes facilities 

for managing the variables in your workspace and importing and exporting data. It also includes tools for 

developing, managing, debugging, and profiling M-files, MATLAB's applications. 

http://whatis.techtarget.com/definition/programming-language-generations
http://whatis.techtarget.com/definition/matrix
http://whatis.techtarget.com/definition/algorithm
http://searchsoa.techtarget.com/definition/user-interface
http://searchbusinessanalytics.techtarget.com/definition/data-visualization
http://whatis.techtarget.com/definition/paradigm
http://whatis.techtarget.com/definition/smart-grid
http://whatis.techtarget.com/definition/robotics
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Handle Graphics. 

This is the MATLAB graphics system. It includes high-level commands for two-dimensional and three- 

dimensional data visualization, image processing, animation, and presentation graphics. It also includes low-level 

commands that allow you to fully customize the appearance of graphics as well as to build complete Graphical 

User Interfaces on your MATLAB applications. 

 

The MATLAB mathematical function library. 

This is a vast collection of computational algorithms ranging from elementary functions like sum, sine, cosine, and 

complex arithmetic, to more sophisticated functions like matrix inverse, matrix eigenvalues, Bessel functions, and 

fast Fourier transforms. 

 

The MATLAB Application Program Interface (API). 

This is a library that allows you to write C and Fortran programs that interact with MATLAB. It include facilities 

for calling routines from MATLAB (dynamic linking), calling MATLAB as a computational engine, and for 

reading and writing MAT-files. 

How to start MATLAB 

Mac: Double-click on the icon for MATLAB. 
PC: Choose the submenu "Programs" from the "Start" menu. From the "Programs" menu, open the "MATLAB" 

submenu. From the "MATLAB" submenu, choose "MATLAB". 

Unix: At the prompt, type matlab. 

 

You can quit MATLAB by typing exit in the command window. 

The MATLAB environment 

Note: From now on an instruction to press a certain key will be denoted by < >, e.g., pressing the enter key will be 

denoted as <enter>. Commands that should be typed at the prompt, will be written in courier font. 

 
The MATLAB environment (on most computer systems) consists of menus, buttons and a writing area similar to an 

ordinary word processor. There are plenty of help functions that you are encouraged to use. The writing area that 

you will see when you start MATLAB, is called the command window. In this window you give the commands to 

MATLAB. For example, when you want to run a program you have written for MATLAB you start the program in 

the command window by typing its name at the prompt. The command window is also useful if you just want to 

use MATLAB as a scientific calculator or as a graphing tool. If you write longer programs, you will find it more 

convenient to write the program code in a separate window, and then run it in the command window. 

 
In the command window you will see a prompt that looks like >> . You type your commands immediately after this 

prompt. Once you have typed the command you wish MATLAB to perform, press <enter>. If you want to interupt 

a command that MATLAB is running, type <ctrl> + <c>. 

 
The commands you type in the command window are stored by MATLAB and can be viewed in the Command 

History window. To repeat a command you have already used, you can simply double-click on the command in the 

history window, or use the <up arrow> at the command prompt to iterate through the commands you have used 

until you reach the command you desire to repeat. 

 
Useful functions and operations in MATLAB 

Using MATLAB as a calculator is easy. 

 

Example: Compute 5 sin(2.53-pi)+1/75. 

 

In MATLAB this is done by simply typing 

5*sin(2.5^(3-pi))+1/75 
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at the prompt. Be careful with parantheses and don't forget to type * whenever you multiply! 

 
Note that MATLAB is case sensitive. This means that MATLAB knows a difference between letters written as 

lower and upper case letters. For example, MATLAB will understand sin(2) but will not understand Sin(2). 

 
Here is a table of useful operations, functions and constants in MATLAB. 

 

Operation, function or constant 
MATLAB 

command 

+ (addition) + 

- (subtraction) - 

 (multiplication) * 

/ (division) / 

|x| (absolute value of x) abs(x) 

square root of x sqrt(x) 

ex exp(x) 

ln x (natural log) log(x) 

log10 x (base 10 log) log10(x) 

sin x sin(x) 

cos x cos(x) 

tan x tan(x) 

cot x cot(x) 

arcsin x asin(x) 

arccos x acos(x) 

arctan x atan(x) 

arccot x acot(x) 

n! (n factorial) gamma(n+1) 

e (2.71828...) exp(1) 

(3.14159265...) pi 

i (imaginary unit, sqrt(-1)) i 



Poornima College of Engineering, Jaipur Department of Mechanical Engineering 

99 

FEA LAB (7ME4-21) Manual 2021-22 

 

 

Exercises 

 
Compute the following expressions using MATLAB: 

 
 3cos(pi) 

 1+1+1/2+1/6+1/24-e 

 ln (1000+2pi-2) 
 e i pi 

 The number of combinations in which 12 persons can stand in line. (Hint: Use factorials.) 

Obtaining Help on MATLAB commands 

To obtain help on any of the MATLAB commands, you simply need to type 

help <command> 

at the command prompt. For example, to obtain help on the gamma function, we type at the command prompt: 

help gamma 

Try this now. You may also get help about commands using the "Help Desk", which can be accessed by selecting 

the MATLAB Help option under the Help menu. 

 
Note that the description MATLAB returns about the command you requested help on contains the command name 

in ALL CAPS. This does not mean that you use this command by typing it in ALL CAPS. In MATLAB, you 

almost always use all lower case letters when using a command. 

 
Variables in MATLAB 

 
We can easily define our own variables in MATLAB. Let's say we need to use the value of 3.5sin(2.9) repeatedly. 

Instead of typing 3.5*sin(2.9)over and over again, we can denote this variable as x by typing the following: 

 
x=3.5*sin(2.9) 

 
(Please try this in MATLAB.) Now type 

x+1 

and observe what happens. Note that we did not need to declare x as a variable that is supposed to hold a floating 

point number as we would need to do in most programming languages. 

 
Often, we may not want to have the result of a calculation printed-out to the command window. To supress this 

output, we put a semi-colon at the end of the command; MATLAB still performs the command in "the 

background". If you defined x as above, now type 

 
y=2*x; 

y 

and observe what happened. 
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In many cases we want to know what variables we have declared. We can do this by typing whos. Alternatively, we 

can view the values by openning the "Workspace" window. This is done by selecting the Workspace option from 

the View menu. If you want to erase all variables from the MATLAB memory, type clear. To erase a specific 

variable, say x, type clear x. To clear two specific variables, say x and y, type clear x y, that is separate the different 

variables with a space. Variables can also be cleared by selecting them in the Workspace window and selecting the 

delete option. 

 
Vectors and matrices in MATLAB 

 
We create a vector in MATLAB by putting the elements within [] brackets. 

 
Example: x=[ 1 2 3 4 5 6 7 8 9 10] 

 
We can also create this vector by typing x=1:10. The vector (1 1.1 1.2 1.3 1.4 1.5) can be created by typing x=[ 1 

1.1 1.2 1.3 1.4 1.5 ] or by typing x=1:0.1:1.5. 

 

 

 
Matrices can be created according to the following example. The matrix A= is created by typing 

A=[1 2 3 ; 4 5 6; 7 8 9], 

i.e., rows are separated with semi-colons. If we want to use a specific element in a vector or a matrix, study the 

following example: 

 
Example: 

 
x=[10 20 30] 

 
A=[ 1 2 3 ; 4 5 6 ; 7 8 9] 

x(2) 

A(3,1) 

 
Here we extracted the second element of the vector by typing the variable and the position within parantheses. The 

same principle holds for matrices; the first number specifies the row of the matrix, and the second number specifies 

the column of the matrix. Note that in MATLAB the first index of a vector or matrix starts at 1, not 0 as is 

common with other programming languages. 

 
If the matrices (or vectors which are special cases of a matrices) are of the same dimensions then matrix addition, 

matrix subtraction and scalar multiplication works just like we are used to. 

 
How to plot with MATLAB 

 
There are different ways of plotting in MATLAB. The following two techniques, illustrated by examples, are 

probably the most useful ones. 

 
Example 1: Plot sin(x2) on the interval [-5,5]. To do this, type the following: 

x=-5:0.01:5; 
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y=sin(x.^2); 

 
plot(x,y) 

 
and observe what happens. 

 
Example 2: Plot exp(sin(x)) on the interval [- 

x=linspace(-pi,pi,101); 

y=exp(sin(x)); 

plot(x,y) 

and observe what happens. The command linspace creates a vector of 101 equally spaced  values between - 

and (inclusive). 

 
Ocassionally, we need to plot values that vary quite differently in magnitude. In this case, the regular plot command 

fails to give us an adequate graphical picture of our data. Instead, we need a command that plots values on a log 

scale. MATLAB has 3 such commands: loglog,semilogx, and semilogy. Use the help command to see a description 

of each function. As an example of where we may want to use one of these plotting routines, consider the following 

problem: 

 
Example 3: Plot x5/2 for x = 10-5 to 105. To do this, type the following: 

 
x=logspace(-5,5,101); 

y=x.^(5/2); 

plot(x,y) 

 
and observe what happens. Now type the following command: 

 
loglog(x,y) 

 
The command logspace is similar to linspace, however it creates a vector of 101 points lograthmically equally 

distributed between 10-5 and 105. 

 
The following commands are useful when plotting: 

 

Graphing functions MATLAB command 

Label the horizontal axis. xlabel('text') 

Label the vertical axis. ylabel('text') 

Attach a title to the plot. title('text') 

Change the limits on the x and y axis. axis([xmin xmax ymin ymax]) 

"Keep plotting in the same window." hold on 

Turn off the "keep-plotting-in-the-same-window-command". hold off 
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Note that all text must be put within ' '. The last two commands (hold on and hold off) are best explained by trying 

them next time you plot. 

 
Viva Questions:- 

 

1. What is The MATLAB working environment? 

2. What is Simulink? 

3. What is 3D-Visualization elements in MATLAB? 

4. What are the basic Plots and Graphs of MATLAB? 

5. What Is Stress Analysis in MATLAB? 

6. Explain MATLAB API (Application Program Interface)? 

7. What does MATLAB consist of? 

8. Explain what is MATLAB? Where MATLAB can be applicable? 

9. How to run MATLAB code? 

10. How to write function in MATLAB? 
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Problem Specification:- 

Consider an aluminum beam that is clamped at one end, with the following dimensions. 

The aluminum used for the beam has the following material properties. 

Experiment No.9. Cantilever Beam Modal Analysis by Using MATLAB 
 

Objective:- To find the Natural frequency & mode shapes of a cantilever beam 

• Modal analysis in structural mechanics is to determine the natural mode shapes and frequencies of an 

object or structure during free vibration. Modal analysis is used to determine a structure’s vibration 

characteristics — natural frequencies and mode shapes. 

• It is the most fundamental of all dynamic analysis types and is generally the starting point for other, more 

detailed dynamic analyses. 

• Modal analysis, or the mode-superposition method, is a linear dynamic-response procedure which 

evaluates and superimposes free-vibration mode shapes to characterize displacement patterns. Mode shapes 

describe the configurations into which a structure will naturally displace. Typically, lateral displacement 

patterns are of primary concern. Mode shapes of low-order mathematical expression tend to provide the 

greatest contribution to structural response. As orders increase, mode shapes contribute less, and are 

predicted less reliably. It is reasonable to truncate analysis when the number of mode shapes is sufficient. 

• A structure with N degrees of freedom will have N corresponding mode shapes. Each mode shape is an 

independent and normalized displacement pattern which may be amplified and superimposed to create a 

resultant displacement pattern. 

 

 

 

Length 4 m 

Width 0.346 m 

Height 0.346 m 

  

 

 
 

Density 2,700 kg/m^3 

Youngs Modulus 70x10^9 Pa 

Poisson Ratio 0.35 

Using Matlab find the first six natural frequencies of the beam and the mode shapes. 

 

Results Required:- 1. Frequency tabular data 2. Mode shapes (6) 

 

 

 
Pre-Analysis 

The following equations give the frequencies of the modes and the mode shapes and are derived from Euler- 

Bernoulli Beam Theory. 

https://en.wikipedia.org/wiki/Modal_analysis
https://en.wikipedia.org/wiki/Vibration
https://wiki.csiamerica.com/display/kb/Nonlinear
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MATLAB Script:- 

 

function cbeam2(~) 

clear all; 

clc; 

 

W=input('Enter Width of the X-section in [m]: '); 

Th=input('Enter Thickness of the X-section in [m]:'); 

L=input('Enter Length in [m]: '); 

Ix=(1/12)*W*Th^3; 

Iy=(1/12)*(W^3)*Th; 

A=W*Th; 

disp('Material properties of the beam') 

disp('Do you know your beam"s material properties, viz. Young"s modulus and density ?') 

 

E=input('Enter Young"s modulus in [Pa]: '); 

Ro=input('Enter material density in [kg/m^3]: '); 

 

display('How many modes and mode shapes would you like to evaluate ?') 

HMMS=input('Enter the number of modes and mode shapes to computed: '); 

if HMMS>=7 

disp(' ') 
warning('NOTE: Up to 6 mode shapes (plots) are displayed via the script. Yet, using evaluated data (Xnx) of the 

script, more mode shapes can be plotted'); 

disp(' ') 

end 

Nm=3*HMMS; 

jj=1; 
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while jj<=Nm; 

betaNL(jj)=fzero(@(betaNL)cosh(betaNL)*cos(betaNL)+1,[jj jj+3]); 

jj=jj+3; 

end 

index=(betaNL~=0); 

betaNLall=(betaNL(index))'; 
%fprintf('betaNL value is %2.3f\n', betaNLall); 

betaN=(betaNLall/L)'; 

k=1; 

wn=ones(1,length(betaN)); 

fn=ones(1,length(wn)); 

while k<=length(betaN); 

wn(k)=betaN(k)^2*sqrt((E*Ix)/(Ro*A)); 

fn(k)=wn(k)/(2*pi); 

fprintf('Mode shape # %2f corresponds to nat. freq (fn): %3.3f\n', k, fn(k) ); 

k=k+1; 

end 
x=linspace(0, L, 180); 

xl=x./L; 

sigmaN=zeros(1, HMMS); 

for ii=1:HMMS; 

sigmaN(ii)=(sinh(betaN(ii)*L)-sin(betaN(ii)*L))/(cosh(betaN(ii)*L)+cos(betaN(ii)*L)); 

end 

Tc='(cosh(betaN(ii).*x(jj))-cos(betaN(ii).*x(jj)))-sigmaN(ii).*(sinh(betaN(ii).*x(jj))-sin(betaN(ii)*x(jj)))'; 

Xnx=zeros(length(betaN),length(x)); 

for ii=1:length(betaN) 

for jj=1:length(x) 

Xnx(ii,jj)=eval(Tc); 

end 

end 
% Plot mode shapes; 

MMS=HMMS; 

if MMS==1 

plot(xl,Xnx(1,:), 'b-') 

title('Mode shape of the Cantilever beam') 

legend('Mode #1', 0); xlabel('x/L'); ylabel('Mode shape X_n(x)'); grid 

hold off 

elseif MMS==2 

plot(xl,Xnx(1,:), 'b-'); hold on 

plot(xl,Xnx(2,:), 'r-');grid 
title('Mode shapes of the Cantilever beam') 

legend('Mode #1', 'Mode #2', 0) 

xlabel('x/L'); ylabel('Mode shape X_n(x)') 

hold off; 

elseif MMS==3 

plot(xl,Xnx(1,:), 'b-'); hold on 

plot(xl,Xnx(2,:), 'r-') 

plot(xl,Xnx(3,:), 'm-');grid 
title('Mode shapes of the Cantilever beam') 

legend('Mode #1', 'Mode #2', 'Mode #3', 0) 

xlabel('x/L'); ylabel('Mode shape X_n(x)') 

hold off; 

elseif MMS==4 

plot(xl,Xnx(1,:), 'b-'); hold on 
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plot(xl,Xnx(2,:), 'r-') 

plot(xl,Xnx(3,:), 'm-') 

plot(xl,Xnx(4,:), 'c-'); grid 

title('Mode shapes of the Cantilever beam') 

legend('Mode #1', 'Mode #2', 'Mode #3', 'Mode #4', 0) 

xlabel('x/L'); ylabel('Mode shape X_n(x)') 

hold off; 

elseif MMS==5 

plot(xl,Xnx(1,:), 'b-'); hold on 

plot(xl,Xnx(2,:), 'r-') 

plot(xl,Xnx(3,:), 'm-') 

plot(xl,Xnx(4,:), 'g-') 
plot(xl,Xnx(5,:), 'k-') 

grid 

title('Mode shapes of the Cantilever beam') 
legend('Mode #1', 'Mode #2', 'Mode #3', 'Mode #4', 'Mode #5', 0) 

xlabel('x/L'); ylabel('Mode shape X_n(x)') 

hold off 

elseif MMS>=6 

plot(xl,Xnx(1,:), 'b-'); hold on 

plot(xl,Xnx(2,:), 'r-') 

plot(xl,Xnx(3,:), 'm-') 

plot(xl,Xnx(4,:), 'g-') 

plot(xl,Xnx(5,:), 'k-') 
plot(xl,Xnx(6,:), 'c-') 

grid 

title('Mode shapes of the Cantilever beam') 
legend('Mode #1', 'Mode #2', 'Mode #3', 'Mode #4', 'Mode #5','Mode #6', 0) 

xlabel('x/L'); ylabel('Mode shape X_n(x)') 

hold off 

end 

 

end 
 

 

 

MATLAB Command Prompt:- write cbeam2- Enter 

Required Input as per the Problem Statement 

Rectangular Plate 
Length (L) = 4 m 

Width (w) = 0.346 m 
Height (h) = 0.346 m 

Young Modulus = 70 x 109 

Density = 2700 Kg/m3 
Mode = 6 

 

 

 

 

 

Results: 

Mode shape # 1.000000 corresponds to nat. freq (fn): 17.787 

Mode shape # 2.000000 corresponds to nat. freq (fn): 111.469 
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Mode shapes of the Cantilever beam 

2.5 

2 

1.5 

Mode #1 

Mode #2 

Mode #3 

Mode #4 

Mode #5 

Mode #6 

60 

50 

1 

0.5 40 

0 

30 

-0.5 

-1 20 

-1.5 

10 

-2 

-2.5 
0 0.1 0.2 0.3 0.4 0.5 

x/L 

0.6 0.7 0.8 0.9 1 

Viva Questions:- 

Mode shape # 3.000000 corresponds to nat. freq (fn): 312.118 

Mode shape # 4.000000 corresponds to nat. freq (fn): 611.626 

Mode shape # 5.000000 corresponds to nat. freq (fn): 1011.062 

Mode shape # 6.000000 corresponds to nat. freq (fn): 1510.351 
 

 

 

 

 

 

 

 

 

1. List out the operators that MATLAB allows? 

2. What is the type of program files that MATLAB allows to write? 

3. How to call a function in MATLAB? 

4. What is MATLAB used for? 

5. How to run MATLAB code? 

6. How to write function in MATLAB? 

7. What is MATLAB software? 

8. How to stop a program in MATLAB? 

9. How to resize an image in MATLAB? 

10. Explain MATLAB API (Application Program Interface)? 
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